Tuesday, 10 January 2012

Installing Metasploit on Windows

Ok, we have downloaded the installer.

Now, find where it has been saved and right click on it.

image

Run this as Administrator. Without, many things will not work. Do the normal bit to accept this and then you will come up with the install banner:

image

Click next and accept the agreement:

image

Select the location to install this:

image

Select the port to run Metasploit on:

image

Generate an SSL cert:

image

Then leave it as default as allow it to update:

image

And we are ready to install by clicking “Next”:

image

Make a coffee as it installs:

image

You should also check that the files are not being stopped by your Anti-Virus program:

image

Well it is installed:

image

Let us click “Finish” and run it.

Click Start –> Run and select the console (“Metasploit Console”):

image

From the console we have the start of our CLI:

image

Tomorrow we go through using it.

Some Specs:

There are a number of specifications on the Metasploit site for the current Windows version. I would take these with a grain of salt. Like all developer specs, they relate mildly to a base install and a slow run. I would personally say the following as a minimum:

  • 2.8 GHz+ processor
  • 4 GB RAM  (If there are any VM targets on the same device just keep adding RAM)
  • 500MB+ available disk space
  • 100 Mbps/ 1 Gbps network interface card (add wireless for tests over wireless)

Less than this and it may run, but it is slow as a dog with a broken leg and it can crash making the process a waste of time.

On top of this, I would change the systems to:

  • Windows XP SP2 or SP3,
  • Windows 2003 Server,
  • Windows Vista SP1 + (and 8 GB ram),
  • Windows 2008 Server (with WAY more specs), and
  • Windows 7 (make it 6 GB ram)

In addition, you need to have a web browser. I would stick with one of the following (and prefer it not to be IE):

  • Mozilla Firefox 5.0+
  • Microsoft Internet Explorer 9 +
  • Google Chrome 10+

Tomorrow we will start to use Metasploit on a target.

6 comments:

Anonymous said...

Hi, I am using windows xp service pack 2, installed metasploit but i got up a pop-up saying that i should disable my anti-virus for the tool to run properly, did so. Now, after that I am facing this problem of booting time upto 3-4 minutes and my audio driver has problem and my system hangs or freezes just like that. Mine is lenovo z370 and its a new one- just 4 days old. Can you guide me further?

Craig Wright said...

My recommendation is to either use the BackTrack Linux distro and a VM or boot to the CD or to have dedicated system/VM for running Metasploit.

http://www.backtrack-linux.org/downloads/

Come To Learn said...

Well i'm installing this on OS XP SP-2. but it is not installing. is there any other requirement for installation ???


http://www.cometohack86.blogspot.com/

Craig Wright said...

Many, they are listed on the site, but I would not run it on XP - you are really wasting your time if you are.

The stack does not support it.

Null Server said...

can i contribute with you in this cool blog ?

Craig Wright said...

I hope many people contribute and in a couple days I shall be loading some details on how.